WordPress PHP waarschuwing: toelichting

Mogelijk toont sinds maandag 26 augustus 2019 uw WordPress een (onterechte) waarschuwing dat er een PHP update vereist is in verband met een onveilige versie. Deze notificatie klopt helaas niet, maar kan wel voor de nodige verwarring zorgen. Uw huidige PHP-versie (5.6 branch) wordt door onze Linux distributie nog t/m volgend jaar voorzien van security updates. Er is dus geen reden tot zorg.

Naar verwachting zullen nieuwe WordPress versies vanaf circa December 2019 wel minimaal PHP versie 7.0 nodig hebben, dus binnenkort zal naast de huidige PHP-versie 5.6 ook de beschikking komen over PHP versies 7.2 en 7.3 om uw website op te laten draaien. Houdt u er wel rekening mee dat uw thema’s/layouts, plugins en customizations hier mogelijk niet mee overweg kunnen en dan vervangen dienen te worden. U kunt eventueel van tevoren deze PHP Compatibility Checker plugin gebruiken om globaal te controleren of uw thema’s/plugins etc compatibel zijn met de nieuwe PHP versies. U kunt het controleren, vervangen of aanpassen hiervan natuurlijk ook aan ons uitbesteden, neem daarvoor a.u.b. contact met ons op.

Update: inmiddels zijn PHP 7.2 en PHP 7.3 beschikbaar.


wordpress     Joomla     RoundCube   NextCloud   Softaculous     ISPConfig     PhpMyAdmin    MySQL   PHP     Debian